BasBQ
Beef en Steak

Cheap Ass Controller gebouwd

Waltair

Tondelzoeker
Berichten
8
hallo allemaal,



ik heb aan de hand van bouwtekeningen op dit forum een BBQ controller gemaakt
dus allereerst mijn grote dank aan ejdb : https://www.bbqgenootschap.nl/threa...oller-incl-onderdelen-ssr-dc-dc-versie.20978/


het goede nieuws : het is gelukt :D ik heb de BBQ Controller in elkaar geknutseld en hij doet het!


maar.... nu het slechte nieuws


er zat een enorm temperatuur verschil tussen de temperatuur die ik in de BBQ meet (met een grilleye)
en de gemeten temperatuur van de controller (zo'n 40 graden verschil maximaal)


grootste probleem is de trage temperatuurmeting van de controller
de meting liep heeel langzaam op (+/- 1 graad per minuut omhoog) terwijl de grilleye al veel sneller een hogere temperatuur aangaf


door dat grote verschil heb ik de temperatuur toen maar geregeld op de oldskool manier met boven en onder meer open en dicht


toen ik de gewenste temperatuur had heb ik onder helemaal dicht gezet en na ongeveer een half uur kwam de controller bij en toen werkte het perfect, tot op de graad nauwkeurig


dit hele gebeuren heeft bijna een uur geduurd!


hoe kan ik dit versnellen?
komt het doordat de probe van de controller niet snel genoeg kan meten? of moet ik nog iets calibreren ofzo?


Alvast bedankt voor de hulp

PS
ik heb wat foto's bijgevoegd, op de laatste foto kun je het verschil goed zien.
de grilleye meet 96 graden, terwijl de controller pas 60 graden meet...

IMG_20221016_133354.jpg


IMG_20221016_133405.jpg


IMG_20221016_162422.jpg
 

Stijn

Gemarineerd
 
 
 
Berichten
1.299
is de probe van je CAC niet te dik zodat hij meer inertie heeft en minder snel opwarmt?

Lijkt mij eerder aan de probe te liggen als aan de controller.
Die geeft maar gewoon weer dat de sensor meet.

Heb je die probe al eens in kokend water gestoken?
Dan zou die 100°C moeten zijn.
 

Ewald

Administrator
Forumleiding
 
 
 
 
Berichten
4.577
Misschien een vreemde opmerking, kan het zo zijn dat je de polariteit (draden) van de probe zelf verkeerd om hebt aangesloten?
Ik zie dat daar een polariteit (+ en -) aan zit.
Ooit een keer een thermostaat gebouwd voor een aquarium daar had ik 1 diode verkeerd gemonteerd + en - omgedraaid en die deed toen ook heel vreemd
 

Waltair

Tondelzoeker
Berichten
8
@Stijn

Het thermokoppel is inderdaad wat dikker want ik moest de gaatjes van het klemmetje uitboren,
zou dat de snelheid zoveel beinvloeden? dat lijkt me toch sterk.

@ Ewald
ik heb alles gecheckt en gedubbelcheckt dus volgens mij moet het goed zitten, heb de gesoldeerde draden daarna met krimpkous samen "gesmolten" dus kan het niet meer zien zonder de krimpkous weg te snijden (en dat doe ik liever niet qua beschadigen)

ik kan eventueel wel de draden even omkeren in de PID...
weet je zeker dat ik daarmee niets kapot kan maken, anders probeer ik dat
 

Ewald

Administrator
Forumleiding
 
 
 
 
Berichten
4.577
ik kan eventueel wel de draden even omkeren in de PID...
weet je zeker dat ik daarmee niets kapot kan maken, anders probeer ik dat
Dat weet ik niet 100% zeker.
Misschien heeft @Stijn daar een antwoord op
 

Just Vodka

Kooltjesharker
 
Berichten
235
Misschien iets mis bij de bedrading?
Thermokoppel werking weet ik niet zo goed en het effect op lamgere en kortere draden. Maar bij thermistors (meest gebruikt bij bbq thermometers) kan dit uitmaken. Thermistors hebben een andere weerstand bij verschillende temperaturen. En als het draad beschadigd is kan je gekke waarden zien.
Maar gezien het bij jou naar verloop van tijd weer goed kwam vind ik het raar.
Misschien alleen binnen een bepaalde range nauwkeurig?
Amdere curve dan waar de electronica vanuit gaat?
 

Stijn

Gemarineerd
 
 
 
Berichten
1.299
@Stijn

Het thermokoppel is inderdaad wat dikker want ik moest de gaatjes van het klemmetje uitboren,
zou dat de snelheid zoveel beinvloeden? dat lijkt me toch sterk.
Probeer eens van kamertemperatuur in koken water, kijk hoe snel hij oploopt en of de temperatuur wel klopt.
Dit zou sowieso sneller moeten gaan als in de lucht want een vloeistof geleidt beter en je maakt beter contact met je probe.

@ Ewald
ik heb alles gecheckt en gedubbelcheckt dus volgens mij moet het goed zitten, heb de gesoldeerde draden daarna met krimpkous samen "gesmolten" dus kan het niet meer zien zonder de krimpkous weg te snijden (en dat doe ik liever niet qua beschadigen)

ik kan eventueel wel de draden even omkeren in de PID...
weet je zeker dat ik daarmee niets kapot kan maken, anders probeer ik dat

Normaalgezien gaat er niets kapot, je zou rare waardes moeten krijgen.
maar aangezien hij hier uiteindelijk toch de correcte waarde aangeeft lijkt het mij sterk dat hij foutief is aangesloten.
 

Waltair

Tondelzoeker
Berichten
8
bedankt voor al jullie input,
ik ga vanavond eerst de aansluiting van het thermokoppel directer op de PID aansluiten,
er zaten af fabriek u vormige stekkers aan en daar heb ik draadjes aangesoldeerd maar dat kan dus beter direct via de stekkers op de PID

ik hou jullie op de hoogte!
 

Veluwse Bob

Kooltjesharker
 
 
Berichten
115
Grappig project ;) heb er zelf allemaal de ballen verstand van maar vind zulke dinge altijd wel leuk om te lezen
 
Bovenaan Onderaan